Help Needed

General Mini and non-Mini related chat.

Moderators: PhillB, Jonesy, timmy201, Sir Alec

Help Needed

Unread postby Ryan » Fri Jul 27, 2018 10:45 am

Hi All,

I'm having trouble getting my mini to start. It appears to be the ignition system, as I can't see a spark.

Does anyone have a spare set of leads and coil that I could use to test it, or if anyone has some time to give me their opinion/help that would be much appreciated. I need this sorted ASAP as it has run out of rego and I need to renew it before the 3 months are up.

Cheers
Ryan
Ryan
 
Posts: 50
Joined: Thu Nov 27, 2014 4:07 pm

Re: Help Needed

Unread postby Trevor » Sun Jul 29, 2018 9:06 pm

Ryan,
Did you have any luck getting your car sorted? I have been tied up with things up to now so could not offer assistance, if you still need help & have time after work this week let me know when. I would not be able to help on Thursday or Friday.
Trevor
 
Posts: 183
Joined: Tue Dec 16, 2014 8:37 pm

Re: Help Needed

Unread postby PhillB » Mon Jul 30, 2018 6:32 am

Hi Ryan. I have spare coils and leads u are welcome to borrow. If I have time to drop in I’ll let u know. Otherwise u can pickup from thirroul Can leave stuff out if not home.

Do you have points or electronic ign. Worth checking however I don’t have spare points or ign module.
Image
68 Morris Cooper S Mk1 (*ex 78 1275 LS 4th last built, 70 Morris 1500 OHC & 70 MiniMatic)
User avatar
PhillB
 
Posts: 646
Joined: Thu Nov 27, 2014 5:05 am
Location: Wollongong

Re: Help Needed

Unread postby Ryan » Mon Jul 30, 2018 6:50 pm

Thanks Trevor and Phil for both of your offers.

I got the car to start, but it is missing under load and running very rough.
Trevor, I will contact you tomorrow if I am available on Wednesday.

To answer your question Phil, I have an electronic module in it.
When I got it running, it seemed to have consistent spark on all cylinders, so now I'm a bit confused.

Regards
Ryan
Ryan
 
Posts: 50
Joined: Thu Nov 27, 2014 4:07 pm

Re: Help Needed

Unread postby PhillB » Fri Aug 03, 2018 1:57 pm

hi Ryan. I thought I already replied earlier but it must have not sent.

There’s a good chance it is just stale fuel esp if it’s ages since you driven it. I’ve been told it starts to deteriorate after 2 weeks. I think it could be worse when the tank is less full. We never notice with our modern cars because their computers can compensate. I was having issues with starting and driving mine and once I got fresh fuel it was much better.

Another item to consider is the spark plugs. Mine kept missing badly esp when cold/damp. There must have been a dud plug as once replace issue was gone. They looked fine though, must have had a crack in the ceramic insulation.
Image
68 Morris Cooper S Mk1 (*ex 78 1275 LS 4th last built, 70 Morris 1500 OHC & 70 MiniMatic)
User avatar
PhillB
 
Posts: 646
Joined: Thu Nov 27, 2014 5:05 am
Location: Wollongong

Re: Help Needed

Unread postby Ryan » Sun Aug 19, 2018 1:24 pm

Thanks Phil,

I hadn't considered fuel. Plugs are new.

I got the car running today. It would only start if I had the tiniest amount of choke on and even then it ran really rough and wouldn't stay running. Finally with a bit of patients, it started to idle, although rough. I took it out onto the street and it ran really badly under load with a lot of backfiring. After about 3 laps of the street, it came good and I was able to drive it like normal.

I feel as though it could be something to do with the choke sticking, but wouldn't mind a second opinion. I'm also interested to see if it will start from cold again.

Ryan
Ryan
 
Posts: 50
Joined: Thu Nov 27, 2014 4:07 pm

Re: Help Needed

Unread postby PhillB » Mon Aug 20, 2018 12:56 pm

I had a similar problem on Rylstone. I checked the float levels and they were a bit low and adjusted and I topped up the dashpot oil with fresh "sewing machine" oil. but I also swapped plugs, cap and leads ....so I will slowly swap things back if I want to find out which was the actual fix. Seems to be OK ....for now. I got a new coil during Rylstone too and that helped but not total fix)

Ive also been told to check the electronic pickup is firmly and tightly fitted still inside the dissy. Check all your spade connections for the ign/coil including the fuse box and back of ign switch, they do work their way loose.
Image
68 Morris Cooper S Mk1 (*ex 78 1275 LS 4th last built, 70 Morris 1500 OHC & 70 MiniMatic)
User avatar
PhillB
 
Posts: 646
Joined: Thu Nov 27, 2014 5:05 am
Location: Wollongong

Re: Help Needed

Unread postby LewisGuy » Sat Aug 25, 2018 4:20 pm

Hi! Have you considered points gap? Providing it is a points ignition system. Too big a gap will cause it to miss at revs. Also faulty condenser will give bothers that mimic fuel starvation. I’ve also had the distributor jump out of the pinch plate and the timing to go out.
Kind regards,
Guy
LewisGuy
 
Posts: 1
Joined: Sat Aug 25, 2018 11:53 am


Return to General Forum

Who is online

Users browsing this forum: No registered users and 0 guests

cron