Primera p11-144 | BT ELM327 connection issues

Discussions related to Nissan DataScan II (NDSII) Windows PC software.
Post Reply
kwd
Posts: 2
Joined: 24 Apr 2019, 01:54

Primera p11-144 | BT ELM327 connection issues

Post by kwd » 24 Apr 2019, 02:09

Hi,

I was trying to NDS with me facelifted Primera P11 (qg18de) (dual catalyst / lambda). From information I've found online it should be supported by NDSII via ELM327. I tried both - PC & Android app w/o success.

Following manual, I tried to manipulate Ini timer offset, I also tried "Find ECU" (which returned different scan results depending on config).
Android app shows Ini failed but it is able to connect to ELM327 and read it's version (v1.5).

Also manual suggest that NDSII will not work with ELM327, while Android app says something else.
I didn't install ftdi drivers because I use BT.

Could you suggest proper approach to establishing point of failure and compability with my ELM / car?
How should I interpret "Find ECU" results? Should I try putting all of those values inside the ECM / ODBII fields?
Why those values differs when I set different connection parameters (such DTR or Init Timer offset)? Should I combine settings DTD/ Ini offset settings so that Find ECU scan will inclde ECM default value 0x10?

Regards,
kwd

kwd
Posts: 2
Joined: 24 Apr 2019, 01:54

Re: Primera p11-144 | BT ELM327 connection issues

Post by kwd » 24 Apr 2019, 22:39

Well, I was able to go a bit further with this. Having changed COM port tranmission speed to 38400 kbps it seems that there is some communication, failing however on "Send keep alive".

Post Reply